[ previous ] [ next ] [ threads ]
 To :  "Maciek Kaminski" <maciejka@t...>, yate@v...
 From :  "Roeland Werring" <ruleking@g...>
 Subject :  Re: [yate] Still wavefile segmentation errors.
 Date :  Wed, 25 Oct 2006 17:06:48 +0200
I tried, same problem! Argh!

First recording and then playing file with this commands on rmanager:
call wave/record//audio/test4.alaw 000498654564
call wave/play//audio/test4.alaw 000498654564

Can someone please please please with sugar on top please tell me if this
only me or a regular bug? Im a bit out of solutions, i need this
recording/playing functionality, and for the rest Yate is brilliant, so i do
not want to go in Asterisk hell again.

I installed the newest cvs, applied this patch h
ttp://yate.null.ro/mantis/file_download.php?file_id(&type=bug.

I'm running on Linux debian, i see a special debian folder yate. I just
compiled it with autoconf and make all, should i do maybe something special
for debian in order to solve this bug?

Thank you,

Roeland

 Caller='wave/play//audio/test4.alaw' name='(null)' plan=unknown
pres=allow_user_not_screened, Called plan=unknown
 Call proceeding on channel 1 on span 1
 Extending timeout on channel 1 on span 1
 Ringing our call on channel 1 on span 1
 Extending timeout on channel 1 on span 1
 Answered channel 1 on span 1
 ANSWERing channel 1 on span 1
 Remote answered on zap/1 (1/1/1)
 Hangup REQ on channel 1 on span 1
 Hanging up channel 1 on span 1
 Hanging up zap/1 (1/1/1) in state connected: Normal Clearing
(16)
>>> DataTranslator::detachChain(0x80ba230,0x80b7288)
<<< DataTranslator::detachChain
 ZapSource::~ZapSource() [0x80bd478]
 WaveChan::~WaveChan() wave/3 [0x80b7178]
>>> ThreadPrivate::destroyFunc(0x80bd5c0)
   Condition::acquire [0x80bd5d0]
   Condition::release [0x80bd5d0]
  >>> ThreadPrivate::~ThreadPrivate() (nil) 'ZapSource' [0x80bd5c0]
  <<< ThreadPrivate::~ThreadPrivate()
   Condition::destroying condition [0x80bd5d0]
<<< ThreadPrivate::destroyFunc
 PriSource::~PriSource() [0x80bd478]
 ZapConsumer::~ZapConsumer() [0x80b7288]
 PriConsumer::~PriConsumer() [0x80b7288]
 WaveSource::~WaveSource() [0x80ba230] total•360 stamp•200
 ThreadPrivate terminating pthread 0x80b7100 [0x80b70f8]
>>> ThreadPrivate::destroyFunc(0x80b70f8)
   Condition::acquire [0x80b7108]
   Condition::release [0x80b7108]
  >>> ThreadPrivate::~ThreadPrivate() (nil) 'WaveSource' [0x80b70f8]
  <<< ThreadPrivate::~ThreadPrivate()
   Condition::destroying condition [0x80b7108]
<<< ThreadPrivate::destroyFunc
Segmentation fault


On 10/25/06, Maciek Kaminski  wrote:
>
> Roeland Werring napisa³(a):
> > Hello people,
> >
> > i am keep on nagging everybody with this but i still have the error
> > that, when i make an outgoing call with an wavefile, or simply attach
> > the wavefile to an isdn, and i hangup the line, yate crashes with the
> > well known error:
> >  ThreadPrivate terminating pthread 0x80b2468 [0x80b2460]
> > Segmentation fault
> >
> > What i really would like to know, does anyone else has this error? I
> > have the newest CVS source, i checked the bug tracker, tried to manually
> > addapt Thread.cpp, tried whatever with wavefiles to make the hangup go
> > allright, but still, if the wavefile plays and i drop the call the whole
> > application crashes.
> >
> > Any suggestions?
> >
> > TIA,
> > --
> > Roeland Werring
> >
> Try this patch:
> http://yate.null.ro/mantis/file_download.php?file_id(&type=bug
>
> mk
>



-- 
Roeland Werring

I tried, same problem! Argh!

First recording and then playing file with this commands on rmanager:
call wave/record//audio/test4.alaw 000498654564
call wave/play//audio/test4.alaw 000498654564

Can someone please please please with sugar on top please tell me if this only me or a regular bug? Im a bit out of solutions, i need this recording/playing functionality, and for the rest Yate is brilliant, so i do not want to go in Asterisk hell again.

I installed the newest cvs, applied this patch h ttp://yate.null.ro/mantis/file_download.php?file_id(&type=bug.

I'm running on Linux debian, i see a special debian folder yate. I just compiled it with autoconf and make all, should i do maybe something special for debian in order to solve this bug?

Thank you,

Roeland

<zap/1:ALL> Caller='wave/play//audio/test4.alaw' name='(null)' plan=unknown pres=allow_user_not_screened, Called plan=unknown
<zap:INFO> Call proceeding on channel 1 on span 1
<zap:INFO> Extending timeout on channel 1 on span 1
<zap:INFO> Ringing our call on channel 1 on span 1
<zap:INFO> Extending timeout on channel 1 on span 1
<zap:INFO> Answered channel 1 on span 1
<zap:INFO> ANSWERing channel 1 on span 1
<zap/1:INFO> Remote answered on zap/1 (1/1/1)
<zap:INFO> Hangup REQ on channel 1 on span 1
<zap:INFO> Hanging up channel 1 on span 1
<zap/1:INFO> Hanging up zap/1 (1/1/1) in state connected: Normal Clearing (16)
>>> DataTranslator::detachChain(0x80ba230,0x80b7288)
<<< DataTranslator::detachChain
<zap/1:ALL> ZapSource::~ZapSource() [0x80bd478]
<wave/3:ALL> WaveChan::~WaveChan() wave/3 [0x80b7178]
>>> ThreadPrivate::destroyFunc(0x80bd5c0)
  <ALL> Condition::acquire [0x80bd5d0]
  <ALL> Condition::release [0x80bd5d0]
  >>> ThreadPrivate::~ThreadPrivate() (nil) 'ZapSource' [0x80bd5c0]
  <<< ThreadPrivate::~ThreadPrivate()
  <ALL> Condition::destroying condition [0x80bd5d0]
<<< ThreadPrivate::destroyFunc
<zap/1:ALL> PriSource::~PriSource() [0x80bd478]
<zap/1:ALL> ZapConsumer::~ZapConsumer() [0x80b7288]
<zap/1:ALL> PriConsumer::~PriConsumer() [0x80b7288]
<wave:ALL> WaveSource::~WaveSource() [0x80ba230] total•360 stamp•200
<WARN> ThreadPrivate terminating pthread 0x80b7100 [0x80b70f8]
>>> ThreadPrivate::destroyFunc(0x80b70f8)
  <ALL> Condition::acquire [0x80b7108]
  <ALL> Condition::release [0x80b7108]
  >>> ThreadPrivate::~ThreadPrivate() (nil) 'WaveSource' [0x80b70f8]
  <<< ThreadPrivate::~ThreadPrivate()
  <ALL> Condition::destroying condition [0x80b7108]
<<< ThreadPrivate::destroyFunc
Segmentation fault


On 10/25/06, Maciek Kaminski <maciejka@t...> wrote:
Roeland Werring napisa³(a):
> Hello people,
>
> i am keep on nagging everybody with this but i still have the error
> that, when i make an outgoing call with an wavefile, or simply attach
> the wavefile to an isdn, and i hangup the line, yate crashes with the
> well known error:
> <WARN> ThreadPrivate terminating pthread 0x80b2468 [0x80b2460]
> Segmentation fault
>
> What i really would like to know, does anyone else has this error? I
> have the newest CVS source, i checked the bug tracker, tried to manually
> addapt Thread.cpp, tried whatever with wavefiles to make the hangup go
> allright, but still, if the wavefile plays and i drop the call the whole
> application crashes.
>
> Any suggestions?
>
> TIA,
> --
> Roeland Werring
>
Try this patch:
http://yate.null.ro/mantis/file_download.php?file_id(&type=bug

mk



--
Roeland Werring