[ previous ] [ next ] [ threads ]
 To :  yate@v...
 From :  koochy black <koochy@a...>
 Subject :  h323chan.yate Compile error , again
 Date :  Mon, 11 May 2009 12:21:40 +0200
Hi,

I need some help with compiling Yate with H323 module. If tryed almost
everything. Yate compiles without problems when I donnt use the h323
feauters. I running Ubuntu Hardy, here is my log when I run make

g++ -Wall   -I.. -I.. -O2 -fno-check-new  -fno-exceptions -fPIC
-DHAVE_GCC_FORMAT_CHECK  -export-dynamic -shared
-Wl,--unresolved-symbols=ignore-in-shared-libs
-Wl,--retain-symbols-file,/dev/null -L.. -lyate -o h323chan.yate
-DPHAS_TEMPLATES -D_REENTRANT -DP_HAS_SEMAPHORES
-I/usr/src/ptlib/include -I/usr/src/ptlib/include/ptlib
-I/usr/src/h323plus/include h323chan.cpp -L/usr/src/h323plus/lib
-lh323_linux_x86_r -L/usr/src/ptlib/lib -lpt_linux_x86_r
h323chan.cpp: In function ‘void::ListRegisteredCaps(int)’:
h323chan.cpp:636: error: conversion from
‘__gnu_cxx::__normal_iterator, std::allocator >*,
std::vector,
std::allocator >, std::allocator, std::allocator > > > >’ to non-scalar type
‘__gnu_cxx::__normal_iterator > >’ requested
h323chan.cpp:636: error: no match for ‘operator!=’ in ‘find !=
list.std::vector<_Tp, _Alloc>::end [with _Tp = std::basic_string, std::allocator >, _Alloc =
std::allocator,
std::allocator > >]()’
make[1]: *** [h323chan.yate] Error 1
make[1]: Leaving directory `/usr/src/yate/modules'
make: *** [modules] Error 2

During ./configure the script finds H323 libs. I've tryed a lot, but the
error is still the same. I have tryed:
- install openh323 libs with apt-get
- compile the Version from yats site, but I'm getting some erros while
make is running.
- compile the 1.19.01 OpenH323 from Sourcefroge and from cvs, works fine
expect of make install for openh323, it looks lite the Makefile has some
bug in the install part
- compile the newest Version from H323Plus 1.20.2  (I've tryed cvs too),
works fine expect of make install for h323plus, same problem like the
openh323 version.

PTLib / PWLib always compiles and installes without a problem. I've also
exported the Vars:
    export PTLIBDIR=/usr/src/ptlib
    export PWLIBDIR=/usr/src/ptlib
    export OPENH323DIR=/usr/src/h323plus
    export LD_LIBRARY_PATH=$PTLIBDIR/lib:$OPENH323DIR/lib

I've coped the lib files from $PTLIBDIR/lib and $OPENH323DIR/lib to /usr/lib
Well thast all I've tryed for days, so it would be super great if
someone could give me an advise or a solution.
Thanks