[ previous ] [ next ] [ threads ]
 To :  yate@v...
 From :  Koochy Black <koochy@a...>
 Subject :  Re: [yate] H323 Registration to a Gatekeeper
 Date :  Tue, 14 Jul 2009 18:38:31 +0200
@Diana:
It looks like you are right, with the password issue:

  2:11.480          Transactor:b60010b8    h235auth1.cxx(555)   H235RAS
H235AuthProcedure1 hash does not match.
  2:11.480          Transactor:b60010b8     h235auth.cxx(426)   H235RAS
Authenticator H235AnnexD_Procedure1 failed: 4
  2:11.480          Transactor:b60010b8    h323trans.cxx(908)   Trans  
RRQ rejected, security tokens invalid.

but I'm 100% sure that I've used the right one. I've tried to connect
without a password and it worked.
Well is there a difference between :

; password: string: Password for h.235 authentification
password = 201
 
and

password=201

could be this the problem? Is there a way to declare the string like:
password="201" or password='201'

Is there a differences in the HMAC-SHA1-96 algorithm in the yate
subversion, probably not...

Thanks for your help

Is the
Diana Cionoiu schrieb:
> Hello,
>
> Probably the password it's not correct.
>
> Regards,
> Diana
>
> Koochy Black wrote:
>> Hi,
>>
>> I've some problem to connect two yate server via h323. The one is setup
>> as a Gatekeeper the other one as a Gateway, which has to register with
>> the GK. I've set-up the same configurations, like faststart,
>> tunneling....but whatever I try the Gateway won't connect to the GK, the
>> error is:
>>
>> / Failed to connect '' to GK addr '192.168.10.130'
>>
>> /- What should be in the '', I've filled the gkname and gkip, but it's
>> still is emtpy
>> - I've tried with a H323 Softphone (MyPhone) to connect to the GK, with
>> no errors!
>> - I've changed the debug level of OpenH323 to 7, but I have not found
>> the any usable informations for me:
>>
>> /  1:00.350           Transactor:8bbb9e8    h323trans.cxx(721)  
>> Trans  registrationRequest rejected: undefinedReason
>>   1:00.351           Transactor:8bbb9e8    h323trans.cxx(607)  
>> Trans  Using credentials from request:
>> H235AnnexD_Procedure1,CAT,H235AnnexD_Procedure1,CAT,MD5
>>
>>   1:00.351           Transactor:8bbb9e8    h235auth1.cxx(450)   H235RAS
>> H235AuthProcedure1 requires general ID.
>>   1:00.351           Transactor:8bbb9e8     h235auth.cxx(426)   H235RAS
>> Authenticator H235AnnexD_Procedure1 failed: 2
>>   1:00.352      YateGkRegT...d:08bb5370    h323trans.cxx(686)  
>> Trans  Response to seqnum=34182 had invalid crypto tokens.
>>   1:00.352      YateGkRegT...d:08bb5370     gkclient.cxx(922)  
>> RAS    Failed registration of  with voip2.si-co.net
>>   1:00.352           Transactor:8bbb9e8    h323trans.cxx(373)  
>> Trans  Reading
>>
>> /Is it possible, that the problem is, because I'm using two different
>> subversions?
>>
>> Thanks for the help, best regards
>>
>> koochy black
>>   
>