[ previous ] [ next ] [ threads ]
 To :  yate@v...
 From :  Koochy Black <koochy@a...>
 Subject :  Sending Error Codes, when routing is done in Database
 Date :  Wed, 12 Aug 2009 19:05:21 +0200
Hi again,

We have set-up routing via database..it's working pretty good...but I've
some problems sending error codes back to yate.
Example:

In regexroute.conf sending error workls like:
^123456789$=-;error=noconn

but if I try to make in database it wont work. I've tried some variations:
a)    Giving error code back in the action/location field
 +-----------------------------------------------------------------+-------+-----------+
| location                                                           
                            | error | context   |
+-----------------------------------------------------------------+-------+-----------+
| -;error=busy  | NULL  | sn-xxx |
+-----------------------------------------------------------------+-------+-----------+
I've tried location='error=noauth'...did not work.....

b)    Giving error code in a error filed
+-----------------------------------------------------------------+-------+-----------+
| location                                                        |
error | context   |
+-----------------------------------------------------------------+-------+-----------+
| NULL | busy | sn-xxx|
+-----------------------------------------------------------------+-------+-----------+

c) Giving error code in reason / code Field


But all variation did not work. Do someone have a hint for me.

Thanks in advance