[ previous ] [ next ] [ threads ]
 To :  yate@v...
 From :  Paul Chitescu <paulc@v...>
 Subject :  Re: [yate] Problem compiling yate
 Date :  Mon, 19 Dec 2005 22:17:28 +0200 (EET)
Please provide more info so we'll be able to help you:
- versions of pwlib and openh323
- relevant ./configure output
- compiler command line where make fails
- error message

Example:

PWlib Mimas patch 2 (1.8.7)
OpenH323 Mimas patch 2 (1.15.6)

checking for Pwlib in /usr... installed 1.8.7 RTTI: none
checking for OpenH323 in /usr... installed

g++ -Wall   -I.. -I../.. -O2 -fno-check-new  -fno-exceptions -fPIC 
-DHAVE_GCC_FORMAT_CHECK  -export-dynamic -shared 
-Wl,--retain-symbols-file,/dev/null -L.. -lyate -o h323chan.yate 
-DPHAS_TEMPLATES -D_REENTRANT -DP_HAS_SEMAPHORES -I/usr/include/ptlib 
-I/usr/include/openh323 ../../modules/h323chan.cpp -L/usr/lib -lopenh323 
-L/usr/lib -lpt
/usr/bin/ld: cannot find -lpt


On Mon, 19 Dec 2005, Daniel Galicia wrote:
> Hi All,
> 
> I've tried to install yate using this command:
> 
> ./configure --with-pwlib=$PWLIBDIR --with-openh323=$OPENH323DIR
> 
> where $OPENH323  is /usr/openh323 and $PWLIBDIR is /usr/pwlib.
> 
> But i got some problems about openh323.
> 
> Is there any known bug about it? Somebody can help me installing this with
> Signaling proxy capacity??
> 
> Thanks