[ previous ] [ next ] [ threads ]
 To :  yate@v...
 From :  Paul Chitescu <paulc@v...>
 Subject :  Re: [yate] SIGTRAN
 Date :  Wed, 2 Jun 2010 17:35:13 +0300
Hi, Andrew.

The initialization failure is caused by this bug:
http://yate.null.ro/mantis/view.php?id=209

As a temporary workaround use the same name in the transport as the link:

sigtransport.conf:

[local-link]
type=sctp
local=127.0.0.1:3000
remote=127.0.0.1:3000


ysigchan.conf:

[local-linkset]
type=ss7-mtp3
netind2pctype=ITU
adjacent=ITU,0-0-1
adjacent=ITU,0-0-2
link=local-link

[local-link]
type=ss7-m2pa
sig=local-link
autostart=yes


Paul


On Wednesday 02 June 2010 03:59:06 pm Andrew Checkov wrote:
> Diana,
> 
> 1. In general I need M3UA - I noticed a class SS7M3UA at yate sources.
> 
> 2. I still don't understand where is the problem with sample M2PA config
> taken from your site.
> 
> Andrew Checkov
> 
> 
> > -----Original Message-----
> > From: Diana Cionoiu [mailto:diana-liste@v...]
> > Sent: Wednesday, June 02, 2010 16:25
> > To: Andrew Checkov
> > Cc: 'Paul Chitescu'; yate@v...
> > Subject: Re: [yate] SIGTRAN
> > 
> > Hello Andrew,
> > 
> > Do you want M2UA or M2PA?
> > We support only M2PA.
> > 
> > See http://tools.ietf.org/html/rfc4165
> > 
> > and also
> > 
> > http://tools.ietf.org/html/rfc3331
> > 
> > Regards,
> > Diana
> > 
> > 
> > Andrew Checkov wrote:
> > > Paul,
> > >
> > >
> > > I try to follow your config but some wrong at my server.
> > >
> > > config is exactly the same:
> > > sigtransport.conf:
> > > [localhost]
> > > type=sctp
> > > local=127.0.0.1:3000
> > > remote=127.0.0.1:3000
> > >
> > > ysigchan.conf:
> > > [local-linkset]
> > > type=ss7-mtp3
> > > netind2pctype=ITU
> > > adjacent=ITU,0-0-1
> > > adjacent=ITU,0-0-2
> > > link=local-link
> > >
> > > [local-link]
> > > type=ss7-m2pa
> > > sig=localhost
> > > autostart=yes
> > >
> > > Yate is SVN R3357 compiled with --enable-sctp
> > >
> > > OS is CentOS 5.5
> > > Linux yate.mgline.ru 2.6.18-194.3.1.el5xen #1 SMP Thu May 13 13:49:53
> > EDT
> > > 2010 x86_64 x86_64 x86_64 GNU/Linux
> > >
> > > Here's an exempt from log
> > >
> > >
> > >  Plugin::Plugin("lksctp",true) [0x2b4926eb5ec0]
> > > Loading module LKSCTP
> > > ...
> > >  Plugin::Plugin("sigtransport",true) [0x2b4927f4cce0]
> > > Loaded module SigTransport
> > > ....
> > > Initializing module Signalling Channel
> > >  ISUP Call Controller pointcode-type=ITU
> > format=alaw
> > > plan/type/pres/screen=unknown/unknown/allowed/user-provided
> > > caller-category=ordinary remote-pointcode=1-1-1 SIF/SSF=5/128
> > lockcircuits=
> > > userpartavail=false lockgroup=true outboundsls=cic [0x1706ca70]
> > >  ISUP Call Controller pointcode-type=ITU
> > format=alaw
> > > plan/type/pres/screen=unknown/unknown/allowed/user-provided
> > > caller-category=ordinary remote-pointcode=1-1-1 SIF/SSF=5/128
> > lockcircuits=
> > > userpartavail=false lockgroup=true outboundsls=cic [0x1706cfe0]
> > >  Point code types are 'ITU' [0x1706d6a0]
> > >  Destinations: [0x1706d6a0]
> > > ITU     0-0-1 0
> > > ITU     0-0-2 0
> > >  Attached link (0x1706dc30,'local-link') with SLS=0
> > > [0x1706d6a0]
> > >  Attached L2 user (0x1706d7a0,'local-linkset')
> > [0x1706dc30]
> > >  Factory could not create 'SIGTransport' named 'local-link'
> > >  GenThread::run() [0x1704eda0]
> > >  Detached link (0x1706dc30,'local-link') with SLS=0
> > > [0x1706d6a0]
> > >  Detached L2 user (0x1706d7a0,'local-linkset')
> > [0x1706dc30]
> > >  Attached service (0x1706e0a0,'ss7snm') [0x1706dee0]
> > >  Attached network/router (0x1706dee8,'ss7router')
> > [0x1706e0a0]
> > >  Attached service (0x1706dc30,'ss7mtn') [0x1706dee0]
> > >  Attached network/router (0x1706dee8,'ss7router')
> > [0x1706dc30]
> > >  Attached L3 user (0x1706dee0,'ss7router')
> > [0x1706d6a0]
> > >  Attached network (0x1706d6a0,'local-linkset')
> > [0x1706dee0]
> > >  Failed to initialize 'local-linkset' of type 'ss7-mtp3'
> > >  Detached network (0x1706d6a0,'local-linkset')
> > [0x1706dee0]
> > >  Detached L3 user (0x1706dee0,'ss7router')
> > [0x1706d6a0]
> > >  No routes [0x1706dee8]
> > >
> > >
> > >
> > >
> > >
> > >> -----Original Message-----
> > >> From: Paul Chitescu [mailto:paulc@v...]
> > >> Sent: Wednesday, June 02, 2010 14:06
> > >> To: yate@v...
> > >> Subject: Re: [yate] SIGTRAN
> > >>
> > >> Please look again at:
> > >>
> > >> http://yate.null.ro/pmwiki/index.php?n=Main.Sigtransport#example
> > >>
> > >> I added a linkset example for the loopback M2PA.
> > >>
> > >> For practical applications you would need to configure the transport
> > >> correctly
> > >> (local and remote address:port), point code type, adjacent point
> > code(s)
> > >> and
> > >> regular routes to other point codes.
> > >>
> > >> If you need to connect to a signaling _gateway_ then M2PA is unlikely
> > to
> > >> be
> > >> what you need. We don't have M2UA support yet but we will love to
> > >> implement
> > >> it. However we don't have equipments and requests for it.
> > >>
> > >> Paul
> > >>
> > >>
> > >> On Wednesday 02 June 2010 12:40:47 pm Andrew Checkov wrote:
> > >>
> > >>> Dear Yate,
> > >>>
> > >>> Could you advice how to configure SIGTRAN for signaling gateway -
> > >>>
> > >> there's
> > >>
> > >>> nothing in maillist and you web site has very modest comment on the
> > >>>
> > >> issue:
> > >>
> > >>> sigtransport.conf:
> > >>> [localhost]
> > >>> type=sctp
> > >>> local=127.0.0.1:3000
> > >>> remote=127.0.0.1:3000
> > >>>
> > >>> ysigchan.conf:
> > >>> [local]
> > >>> type=ss7-m2pa
> > >>> sig=localhost
> > >>> autostart=yes
> > >>>
> > >>> How I should configure the link - where I should put local and remote
> > >>> pointcodes?
> > >>>
> > >>> Regards,
> > >>> Andrew Checkov
> > >>>
>