[ previous ] [ next ] [ threads ]
 To :  Sean McKenzie <seanmckenzie@r...>
 From :  Gamaliel Bedolla <gbf@t...>
 Subject :  Re: [yate] Help starting sctp
 Date :  Thu, 20 Oct 2011 19:42:13 -0600
Hi Sean,
It was the issue. Now I have another issues to solve.
Thank you!

2011/10/20 Sean McKenzie 

>  Hi, ****
>
> Assuming you compiled from source, did you remember to enable sctp when you
> ran the configure script? SCTP is not enabled by default.****
>
> ** **
>
> ./configure --enable-sctp****
>
> ** **
>
> That was my issue the first time I tried to get sctp working.****
>
> ** **
>
> Hopefully that helps,****
>
> --Sean****
>  ------------------------------
>
> *From:* Gamaliel Bedolla [mailto:gbf@t...]
> *Sent:* Thursday, October 20, 2011 2:15 PM
> *To:* yate@v...
> *Subject:* [yate] Help starting sctp****
>
> ** **
>
> Hi all,****
>
> ** **
>
> I'm having problems when I start yate. I configured sigtransport.conf to
> use sctp, but until now I'm unable to make it works. Here's what i get in
> /var/log/yate:****
>
> Initializing module SipCnamLnp****
>
> Initialization complete****
>
> 0000000.769028  Engine dispatching start message****
>
> Yate engine is initialized and starting up on localhost****
>
> 0000000.769067  Creating new message dispatching thread (0 running)*
> ***
>
> 0000000.944230  Could not obtain SctpSocket****
>
> 0000000.946968  Could not obtain SctpSocket****
>
> 0000001.448627  Could not obtain SctpSocket****
>
> ** **
>
> Seems the stcp protocol is not well configured, or yate is unable to make
> it work.****
>
> Can you help me to configure it correctly?****
>
> Here's some information :****
>
> lsmod | grep sctp****
>
> sctp                  163119  2****
>
> ipv6                  265637  39 sctp****
>
> libcrc32c                843  1 sctp****
>
> ** **
>
> In sigtransport.conf****
>
> [link1]****
>
> local=201.174.X.X:7100****
>
> remote=204.28.X.X:23140****
>
> type=sctp****
>
> stream=no****
>
> endpoint=yes****
>
> ** **
>
> [link2]****
>
> local=201.174.X.X:7200****
>
> remote=204.28.X.X:23140****
>
> type=sctp****
>
> stream=no****
>
> endpoint=yes****
>
> ** **
>
> Please let me know if any info is needed.****
>
> Thank you****
>
> ** **
>
> ** **
>



Hi Sean,
It was the issue. Now I have another issues to solve.
Thank you!

2011/10/20 Sean McKenzie <seanmckenzie@r...>

Hi,

Assuming you compiled from source, did you remember to enable sctp when you ran the configure script? SCTP is not enabled by default.

 

./configure --enable-sctp

 

That was my issue the first time I tried to get sctp working.

 

Hopefully that helps,

--Sean


From: Gamaliel Bedolla [mailto:gbf@t...]
Sent: Thursday, October 20, 2011 2:15 PM
To: yate@v...
Subject: [yate] Help starting sctp

 

Hi all,

 

I'm having problems when I start yate. I configured sigtransport.conf to use sctp, but until now I'm unable to make it works. Here's what i get in /var/log/yate:

Initializing module SipCnamLnp

Initialization complete

0000000.769028 <ALL> Engine dispatching start message

Yate engine is initialized and starting up on localhost

0000000.769067 <INFO> Creating new message dispatching thread (0 running)

0000000.944230 <Transport:CONF> Could not obtain SctpSocket

0000000.946968 <Transport:CONF> Could not obtain SctpSocket

0000001.448627 <Transport:CONF> Could not obtain SctpSocket

 

Seems the stcp protocol is not well configured, or yate is unable to make it work.

Can you help me to configure it correctly?

Here's some information :

lsmod | grep sctp

sctp                  163119  2

ipv6                  265637  39 sctp

libcrc32c                843  1 sctp

 

In sigtransport.conf

[link1]

local=201.174.X.X:7100

remote=204.28.X.X:23140

type=sctp

stream=no

endpoint=yes

 

[link2]

local=201.174.X.X:7200

remote=204.28.X.X:23140

type=sctp

stream=no

endpoint=yes

 

Please let me know if any info is needed.

Thank you