[ previous ] [ next ] [ threads ]
 To :  yate@v...
 From :  Serge Filatov <filatov.serge@g...>
 Subject :  m2ua and mediant
 Date :  Wed, 16 Jan 2013 10:51:57 +0300
Can anyone help me to connect yate and mediant 2k?


Here is config of yate:
ysigchan.conf

[ISUP_TRUNK1]
type=ss7-isup
pointcodetype=ITU
pointcode=59
defaultpointcode=59
remotepointcode=2
netindicator=national
router=ss7router
voice=TRUNK_1
offset=1
range=name:1-30
presentation=allowed

[ss7router]
type=ss7-router
local=ITU,0-7-3
management=ss7snm
autostart=yes
testroutes=50000

[ss7snm]
type=ss7-snm
local=ITU,0-7-3
netindicator=national


[link0]
type=ss7-m2ua
sig=link0
router=ss7router
iid=0
autostart=no


[ss7_linkset0]
type=ss7-mtp3
autostart=yes
link=link0


sigtransport.conf

[link0]
type=sctp
stream=true
local=192.168.20.183
remote=192.168.30.100:2904
endpoint=true



and the log

 Attached service (0x274c970,'ss7snm')
[0x27442d0]

 Attached network/router (0x27442d8,'ss7router')
[0x274c970]

 Attached network/router (0x27442d8,'ss7router')
[0x2744f48]

 Attached service (0x2744f48,'ISUP_TRUNK1/ISUP')
[0x27442d0]

 Point code types are ''
[0x274d020]

 No outgoing routes
[0x274d020]

 Link inhibition changed 0x01 -> 0x03
[0x274dc70]

 Attached link (0x274dc70,'link0') with SLS=0
[0x274d020]

 Attached L2 user (0x274d140,'ss7_linkset0')
[0x274dc70]

 Transport created
(0x274e660)

 ASP state change: AspDown -> AspUpRq
[0x274e210]

 Cannot send message, stream 0 not connected
[0x274e660]

 Attached L3 user (0x27442d0,'ss7router')
[0x274d020]

 Attached network (0x274d020,'ss7_linkset0')
[0x27442d0]

No routes in 'ss7router'
[0x27442d8]

Initializing module
MrcpSpeech

Initializing module PBX for
database

Initializing module
CCongestion

Initializing module Analog
Channel

Initializing module Queues
Notify

 Query 'callinfo' not
configured

 Query 'cdrinfo' not
configured

 Initialized: account=
notifyhanguponunload=true

Initializing module Radius
client

 Local address not set or invalid. Radius functions
disabled

Initializing module Register for
database

Initializing module Late
Router

Initializing module SNMP
Agent

 Sctp
commUp

 Connection down
[0x7f16d0000970]

 SnmpMsgQueue created for 0.0.0.0:161 with priority
'normal'

 SNMP UDP Listener initialized on port
161

Initializing module
Cache

Initializing module Register from
file

Initializing module Call
Parking

Initializing module
Monitoring

 RTPTable created
[0x27a7360]

 RTPTable [0x27a7360] configured with
directions='(null)',resetTime=3600

Initialization
complete

 Engine dispatching start
message

Yate engine is initialized and starting up on wshp146msk.mango.ru

 Creating new message dispatching thread (0
running)

 Sctp
commUp

 Connection down
[0x7f16d0000970]

 Sctp
commUp

 Connection down
[0x7f16d0000970]

 Sctp
commUp

 Connection down
[0x7f16d0000970]

 Sctp
commUp

 Connection down
[0x7f16d0000970]

 Sctp
commUp

 Connection down
[0x7f16d0000970]

 Sctp
commUp

 Connection down
[0x7f16d0000970]

 Sctp
commUp

 Connection down
[0x7f16d0000970]

 Sctp
commUp

 Connection down [0x7f16d0000970] etc.....


What I'm doing wrong? :)


-- 
WBR,
Serge Filatov



Can anyone help me to connect yate and mediant 2k?


Here is config of yate:
ysigchan.conf

[ISUP_TRUNK1]
type=ss7-isup
pointcodetype=ITU
pointcodeY
defaultpointcodeY
remotepointcode=2
netindicator=national
router=ss7router
voice=TRUNK_1
offset=1
range=name:1-30
presentation=allowed

[ss7router]
type=ss7-router
local=ITU,0-7-3
management=ss7snm
autostart=yes
testroutesP000

[ss7snm]
type=ss7-snm
local=ITU,0-7-3
netindicator=national


[link0]
type=ss7-m2ua
sig=link0
router=ss7router
iid=0
autostart=no


[ss7_linkset0]
type=ss7-mtp3
autostart=yes
link=link0


sigtransport.conf

[link0]
type=sctp
stream=true
local2.168.20.183
remote=192.168.30.100:2904
endpoint=true



and the log

<ss7router:ALL> Attached service (0x274c970,'ss7snm') [0x27442d0]                                                                                                                            
<ss7snm:ALL> Attached network/router (0x27442d8,'ss7router') [0x274c970]                                                                                                                     
<ISUP_TRUNK1/ISUP:ALL> Attached network/router (0x27442d8,'ss7router') [0x2744f48]                                                                                                           
<ss7router:ALL> Attached service (0x2744f48,'ISUP_TRUNK1/ISUP') [0x27442d0]                                                                                                                  
<ss7_linkset0:NOTE> Point code types are '' [0x274d020]                                                                                                                                      
<ss7_linkset0:MILD> No outgoing routes [0x274d020]                                                                                                                                           
<link0:NOTE> Link inhibition changed 0x01 -> 0x03 [0x274dc70]                                                                                                                                
<ss7_linkset0:ALL> Attached link (0x274dc70,'link0') with SLS=0 [0x274d020]                                                                                                                  
<link0:ALL> Attached L2 user (0x274d140,'ss7_linkset0') [0x274dc70]                                                                                                                          
<Transport:ALL> Transport created (0x274e660)                                                                                                                                                
<link0:ALL> ASP state change: AspDown -> AspUpRq [0x274e210]                                                                                                                                 
<Transport:MILD> Cannot send message, stream 0 not connected [0x274e660]                                                                                                                     
<ss7_linkset0:ALL> Attached L3 user (0x27442d0,'ss7router') [0x274d020]                                                                                                                      
<ss7router:ALL> Attached network (0x274d020,'ss7_linkset0') [0x27442d0]                                                                                                                      
No routes in 'ss7router' [0x27442d8]                                                                                                                                                         
Initializing module MrcpSpeech                                                                                                                                                               
Initializing module PBX for database                                                                                                                                                         
Initializing module CCongestion                                                                                                                                                              
Initializing module Analog Channel                                                                                                                                                           
Initializing module Queues Notify                                                                                                                                                            
<queuesnotify:INFO> Query 'callinfo' not configured                                                                                                                                          
<queuesnotify:INFO> Query 'cdrinfo' not configured                                                                                                                                           
<queuesnotify:ALL> Initialized: account= notifyhanguponunload=true                                                                                                                           
Initializing module Radius client                                                                                                                                                            
<yradius:NOTE> Local address not set or invalid. Radius functions disabled                                                                                                                   
Initializing module Register for database                                                                                                                                                    
Initializing module Late Router                                                                                                                                                              
Initializing module SNMP Agent                                                                                                                                                               
<Transport:INFO> Sctp commUp                                                                                                                                                                 
<Transport:MILD> Connection down [0x7f16d0000970]                                                                                                                                            
<snmpagent:ALL> SnmpMsgQueue created for 0.0.0.0:161 with priority 'normal'                                                                                                                  
<snmpagent:INFO> SNMP UDP Listener initialized on port 161                                                                                                                                   
Initializing module Cache                                                                                                                                                                    
Initializing module Register from file                                                                                                                                                       
Initializing module Call Parking                                                                                                                                                             
Initializing module Monitoring                                                                                                                                                               
<monitoring:ALL> RTPTable created [0x27a7360]                                                                                                                                                
<monitoring:ALL> RTPTable [0x27a7360] configured with directions='(null)',resetTime600                                                                                                     
Initialization complete                                                                                                                                                                      
<ALL> Engine dispatching start message                                                                                                                                                       
Yate engine is initialized and starting up on wshp146msk.mango.ru                                                                                                                            
<INFO> Creating new message dispatching thread (0 running)                                                                                                                                   
<Transport:INFO> Sctp commUp                                                                                                                                                                 
<Transport:MILD> Connection down [0x7f16d0000970]                                                                                                                                            
<Transport:INFO> Sctp commUp                                                                                                                                                                 
<Transport:MILD> Connection down [0x7f16d0000970]                                                                                                                                            
<Transport:INFO> Sctp commUp                                                                                                                                                                 
<Transport:MILD> Connection down [0x7f16d0000970]                                                                                                                                            
<Transport:INFO> Sctp commUp                                                                                                                                                                 
<Transport:MILD> Connection down [0x7f16d0000970]                                                                                                                                            
<Transport:INFO> Sctp commUp                                                                                                                                                                 
<Transport:MILD> Connection down [0x7f16d0000970]                                                                                                                                            
<Transport:INFO> Sctp commUp                                                                                                                                                                 
<Transport:MILD> Connection down [0x7f16d0000970]                                                                                                                                            
<Transport:INFO> Sctp commUp                                                                                                                                                                 
<Transport:MILD> Connection down [0x7f16d0000970]                                                                                                                                            
<Transport:INFO> Sctp commUp                                                                                                                                                                 
<Transport:MILD> Connection down [0x7f16d0000970] etc.....


What I'm doing wrong? :)


--
WBR,
Serge Filatov