[ previous ] [ next ] [ threads ]
 To :  yate@v...
 From :  Maciek Kaminski <maciejka@t...>
 Subject :  Re: [yate] yaypm 0.2 problems
 Date :  Mon, 22 May 2006 01:26:14 +0200
Igor napisał(a):
> Hi.
> 
> I tried to use the yaypm 0.2 from the bug tracker, but ran into the following problem:
> 
> Initializing module PyModule
>  Can't load yaypm module:
> Traceback (most recent call last):
>   File "/home/igor/tree/lib/yate/scripts/yaypm/__init__.py", line 26,
> in ? from twisted.internet import reactor, defer
>   File
> "/home/igor/tree/lib/python2.4/site-packages/twisted/__init__.py", line
> 22, in ? raise ImportError, "you need zope.interface installed
> (http://zope.org/Products/ZopeInterface/)" ImportError: you need
> zope.interface installed (http://zope.org/Products/ZopeInterface/)
>  Interpreter not initialized
> 
> The error message is confusing, because twisted and zope.interface is
> installed and working great when I try to use them in a standalone python.

Are You sure that standalone python and python that pymodule links with 
are the same?

> 
> Also yaypm cannot be imported in a standalone python, because yateproxy
> is imported unconditionally in yaypm/__init__.py but is only available
> when running the embedded interpreter.

Version from bugtracker is meant to work only in embedded interpreter. I 
am working on version that will work with extmodule as well.

Maciejk Kaminski