Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000011 [Yate - Yet Another Telephony Engine] module major random 2005-12-13 10:43 2005-12-13 13:05
Reporter jsaunders View Status public  
Assigned To
Priority normal Resolution not fixable  
Status closed   Product Version
Summary 0000011: randomly lose caller/called in call.cdr cdr_initialize message with h323 incoming
Description I have noticed that with inbound h323 caller & called are randomly empty. Initialize operation for call.cdr message is missing appropriate info. It happens fairly often actually. 15 out of 20 calls when I tested, give or take. The other 5, it showed up fine and all was well. Rather odd. I've tested from Versatel gateways & SJPhone, was able to reproduce with both. pwlib 1.9.2 & openh323 1.17.3, latest Yate cvs.
Additional Information %%<message::false:chan.startup::id=h323/1:module=h323:status=incoming:address=xx.xx.xx.xx%z1773:billid=1134458993-1
%%<message::false:call.preroute::id=h323/1:module=h323:status=incoming:address=xx.xx.xx.xx%z1773:billid=1134458993-1:context=default:callername=unknown [xx.xx.xx.xx]:caller=4204204204:called=12345612345678901:rtp_forward=possible:rtp_addr=xx.xx.xx.xx:rtp_port=49160:formats=mulaw,alaw,gsm
%%
<message::true:database::account=local:query=INSERT INTO cdrs_current (direction, prefix, duration, ringtime, protocol, channel, caller, callee, host, gateway, starttime) VALUES ('incoming', SUBSTR('', 1, 6), '0.000', 0.001, SUBSTR('h323/1', 1, POSITION('/' IN 'h323/1') - 1), SUBSTR('h323/1', POSITION('/' IN 'h323/1') + 1)%z%zint, '', SUBSTR('', 7), SUBSTR('xx.xx.xx.xx%z1773', 1, POSITION('%z' IN 'xx.xx.xx.xx%z1773') - 1), 'xx.xx.xx.xx', TIMESTAMP WITH TIME ZONE 'EPOCH' + INTERVAL '1134459006.515 s' + INTERVAL '0.001 s'):rows=0:affected=1
%%<message::false:call.cdr::operation=initialize:time=1134459006.515:chan=h323/1:address=xx.xx.xx.xx%z1773:direction=incoming:billid=1134458993-1:caller=:called=:duration=0.001:billtime=0.000:ringtime=0.001:status=incoming:reason=:external=
%%<message::false:call.cdr::operation=update:time=1134459006.515:chan=h323/1:address=xx.xx.xx.xx%z1773:direction=incoming:billid=1134458993-1:caller=4204204204:called=12345612345678901:duration=0.002:billtime=0.000:ringtime=0.002:status=incoming:reason=:external=4204204204
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000012)
paulc (administrator)
2005-12-13 13:05

In H.323 the call information is sent asynchronously after the connection is opened. This is the reason the incoming call chan.startup does not carry that information - at the time it is generated the info is not available.

Later messages fill the missing values so at finalization time the CDR will have them.

- Issue History
Date Modified Username Field Change
2005-12-13 10:43 jsaunders New Issue
2005-12-13 13:05 paulc Note Added: 0000012
2005-12-13 13:05 paulc Status new => closed
2005-12-13 13:05 paulc Resolution open => not fixable


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker