Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000278 [Yate - Yet Another Telephony Engine] module major always 2011-12-07 19:07 2012-04-21 14:20
Reporter lojza View Status public  
Assigned To paulc
Priority normal Resolution fixed  
Status resolved   Product Version SVN
Summary 0000278: BYE was not send when call is canceled during ringing phase
Description Hello,

We use Yate as SIP-T => SIP translator.

Caller released the call during ringing phase, but called phone
was still ringing.

We have this situation:

host1: host2: host3:
SIP UA [Switch] ---(SIP-T)--- Yate B2BUA(SIP)Asterisk ---(IAX2)----IAX2user
Caller called

Problem - during the ringing phase the caller releases the call (SIP UA generates BYE), but the information is not passed to asterisk. Thus, the called entity doesn't know that the call has been torn down. (picture1) If the call is picked up and then released, the BYE message is passed through. (picture2)

Probably the problem was in receiving "call.ringing" message in function
YateSIPConnection::msgRinging , where is an attempt to set status to
Ringing (2), but really status was not changed and was Incoming (0).

When we fixed this (patch included) ant it starts to work. Both BYE and CANCEL
requests are send as we expected. (picture 3)


Additional Information We are using Yate release 4713
Tags No tags attached.
Attached Files ? file icon fix_ring.diff [^] (276 bytes) 2011-12-07 19:07
png file icon pic1.PNG [^] (49,922 bytes) 2011-12-07 19:08
png file icon pic2.PNG [^] (75,802 bytes) 2011-12-07 19:08
png file icon pic3.PNG [^] (82,910 bytes) 2011-12-07 19:08

- Relationships

-  Notes
(0000451)
paulc (administrator)
2012-04-21 14:20

Fixed in SVN Rev. 4994 (2012-04-04)
Another related issue fixed in SVN Rev. 5017 (2012-04-21)

- Issue History
Date Modified Username Field Change
2011-12-07 19:07 lojza New Issue
2011-12-07 19:07 lojza File Added: fix_ring.diff
2011-12-07 19:08 lojza File Added: pic1.PNG
2011-12-07 19:08 lojza File Added: pic2.PNG
2011-12-07 19:08 lojza File Added: pic3.PNG
2012-01-17 16:23 paulc Assigned To => paulc
2012-01-17 16:23 paulc Status new => assigned
2012-04-21 14:20 paulc Note Added: 0000451
2012-04-21 14:20 paulc Status assigned => resolved
2012-04-21 14:20 paulc Resolution open => fixed


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker