Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000295 [Yate - Yet Another Telephony Engine] engine minor N/A 2012-02-24 00:38 2012-02-24 13:29
Reporter dekkers View Status public  
Assigned To paulc
Priority normal Resolution reopened  
Status feedback   Product Version
Summary 0000295: Yate ships non-free iLBC code, newer BSD-licensed code available
Description While looking at what's needed to update the yate packages in Debian to version 4 I noticed that Debian removes the iLBC library because it's non-free. With the release of the WebRTC project Google has released the code under the BSD license, but just building the iLBC library from the WebRTC sources is pretty difficult. I've created a libilbc project from the WebRTC code, adding the necessary files to build the library and also packaged it for Debian. The project can be found at
https://github.com/dekkers/libilbc [^] and my plan is to get it uploaded in Debian soon.

I think it's a good idea to replace the non-free code with the newer BSD-licensed code. I can provide a patch, but the question is whether iLBC should be included in libs/ as it is now with a configure option to use the system iLBC for distributions like Debian that forbid embedded libraries or Yate just requires libilbc installed in the same way you need libgsm for the gsm codecs. I think the second option is better because I don't like embedded libraries, but I would be willing to write a patch for the first option if that's the preferred way.

P.S. 4.x still needs to be added to the product version in mantis.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000439)
paulc (administrator)
2012-02-24 11:03

After buying the patent owner (GIPS) Google has provided a worldwide no-charge license of using iLBC which explicitely applies to the reference implementation too.

Please see libs/ilbc/LICENSE.txt
(0000440)
dekkers (reporter)
2012-02-24 13:29

That is only a patent license, no copyright license. All the code is still
"Copyright (C) The Internet Society (2004). All Rights Reserved." as written in every source file and with that copyright notice you don't even get a copyright license to use or distribute the code.

- Issue History
Date Modified Username Field Change
2012-02-24 00:38 dekkers New Issue
2012-02-24 11:03 paulc Note Added: 0000439
2012-02-24 11:03 paulc Assigned To => paulc
2012-02-24 11:03 paulc Status new => resolved
2012-02-24 11:03 paulc Resolution open => no change required
2012-02-24 13:29 dekkers Note Added: 0000440
2012-02-24 13:29 dekkers Status resolved => feedback
2012-02-24 13:29 dekkers Resolution no change required => reopened


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker