Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000298 [Yate - Yet Another Telephony Engine] module block always 2012-02-24 20:57 2012-06-01 19:07
Reporter ojab View Status public  
Assigned To paulc
Priority normal Resolution fixed  
Status resolved   Product Version SVN
Summary 0000298: h323chan build is broken since r4928
Description g++ -Wall -I.. -I.. -O2 -fno-check-new -fno-exceptions -fPIC -DHAVE_GCC_FORMAT_CHECK -DHAVE_BLOCK_RETURN -export-dynamic -shared -Wl,--unresolved-symbols=ignore-in-shared-libs -Wl,--retain-symbols-file,/dev/null -o h323chan.yate -I/usr/include -DP_64BIT -DPTRACING=1 -D_REENTRANT -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/SDL -fno-exceptions -I/usr/include/openh323 h323chan.cpp -L/usr/lib64 -lopenh323 -L/usr/lib64 -lpt -L.. -lyate
/tmp/ccDWSEP7.o:(.data.rel.ro._ZTVN9TelEngine8DataNodeE[vtable for TelEngine::DataNode]+0x38): undefined reference to `TelEngine::RefObject::getObject(TelEngine::String const&) const'
collect2: ld returned 1 exit status
make[1]: *** [h323chan.yate] Error 1
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000442)
ojab (reporter)
2012-02-25 05:58
edited on: 2012-02-25 15:11

Linux x86_64, gcc-4.6.2, binutils-2.22, glibc-2.13, h323plus-1.24.0, ptlib-2.10.3

(0000443)
paulc (administrator)
2012-02-27 11:16

Are you sure you are doing a proper clean build?

Looks like you have another (older) libyate.so where RefObject::getObject is not implemented.

Make sure you don't have a yate-devel (or yate-dev) package installed while building Yate. Being in the default search path their libyate.so will be found and used by the linker in preference of the just built one...
(0000445)
ojab (reporter)
2012-02-27 11:45

Looks like h323chan.yate tries to link to system libyate.so instead of in-tree one.
@H323_LIB@ expands to `-L/usr/lib64 -lopenh323 -L/usr/lib64 -lpt` and /usr/lib64 already contains libyate.so.

If I'll delete "-L/usr/lib64" from compilation string — h323chan.yate links fine.

I think that issue can be closed because of my system's misconfiguration or moved from h323chan to build system (something like `-L.. should be placed before other library dirs in modules/Makefile`).
(0000453)
paulc (administrator)
2012-05-23 09:30

Please recheck with SVN >= Rev 5064 (2012-05-17)

Log message:
Moved external code dependencies in separate make variables EXTERNFLAGS and EXTERNLIBS.
This prevents the external dependencies from inserting include and library paths.
Should prevent build failures caused by older Yate devel components in system paths.
(0000454)
ojab (reporter)
2012-05-30 10:10

Yep, fixed.

- Issue History
Date Modified Username Field Change
2012-02-24 20:57 ojab New Issue
2012-02-25 05:58 ojab Note Added: 0000442
2012-02-25 15:11 ojab Note Edited: 0000442
2012-02-27 11:16 paulc Note Added: 0000443
2012-02-27 11:16 paulc Assigned To => paulc
2012-02-27 11:16 paulc Status new => feedback
2012-02-27 11:45 ojab Note Added: 0000445
2012-05-23 09:30 paulc Note Added: 0000453
2012-05-30 10:10 ojab Note Added: 0000454
2012-06-01 19:07 paulc Status feedback => resolved
2012-06-01 19:07 paulc Resolution open => fixed


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker