Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000331 [Yate - Yet Another Telephony Engine] user interface major always 2013-02-06 08:58 2014-07-25 16:19
Reporter evgeniyl View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 4.x
Summary 0000331: YateClient Audio Failure on incoming call
Description A have a problem with my YateClient Yate 4.3.1 alpha1 (svn revision 5391).
And I have seen it on previous releases.

The test case is:
When I have an incoming call on my YateClient and try to answer (by pushing button "Answer the call") I get this message:

Audio failure.
Failed to open audio.
Please check your sound card.

And there is no sound on both clients.

It's repeated for me on :
Ubuntu 10.10 (2.6.35-22-generic 0000033-Ubuntu SMP Sun Sep 19 20:34:50 UTC 2010 i686 GNU/Linux), and
SuSe 12.1 (3.1.10-1.9-desktop 0000001 SMP preempt Thu Apr 5 18:48:38 UTC 2012 (4a97ec8) x86_64 x86_64 x86_64 GNU/Linux)
Additional Information I've found three issues, that can be useful:

1) Everybody can fix this no sound problem by unset the checkbox Ringer in Settings->Options->Telephony. It will be no ringer sound on incoming call, but no "Audio failure" error also.

2) The second way to fix the no sound problem is just pushing the button "Activate/deactivate the call" two times after answering incoming call, and bam! No "Audio failure" error, and sounds back!

3) I tried to repeat it on Mac OS X 10.8.2.But I can't, everything all right in such a case on Mac.

It looks like that the problem in AlsaChan module.
P.S. I didn't check it on Windows yet, but I think I should.
Tags audio
Attached Files

- Relationships

-  Notes
(0000549)
paulc (administrator)
2014-07-25 16:19

Fixed in SVN Rev 5879.

- Issue History
Date Modified Username Field Change
2013-02-06 08:58 evgeniyl New Issue
2013-02-06 08:59 evgeniyl Tag Attached: audio
2014-07-25 16:19 paulc Note Added: 0000549
2014-07-25 16:19 paulc Status new => resolved
2014-07-25 16:19 paulc Resolution open => fixed


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker