Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000368 [Yate - Yet Another Telephony Engine] module crash sometimes 2014-07-03 12:59 2014-07-03 13:51
Reporter fed View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0000368: a crash in exmodule.cpp
Description When I upgraded my yate from 5.0 to 5.3 , a crash has started to happen occasionally.

I see that ExtModReceiver::outputLine was splited up to
ExtModReceiver::outputLine and
ExtModReceiver::outputLineInternal

in logs I see the last string:
20140702204920.334916 <ExtModule:INFO> Read EOF on 0x7f0e7c000b00 [0x7f0e7c0024e0]
Supervisor: child 26973 died on signal 11

Perhaps something wrong in the new source code.

Additional Information Core was generated by `/usr/local/bin/yate -d -p /var/run/yate.pid -vvvvvvvvvv -d -s -r -C -F -Dz -p /'.
Program terminated with signal 11, Segmentation fault.
#0 0x00007f0ec5d9ea64 in outputLineInternal (this=0x7f0e7c0024e0, line=<value optimized out>)
    at extmodule.cpp:1250
1250 if ((w < 0) && m_out->canRetry())

Thread 1 (Thread 0x7f0ec3164700 (LWP 5001)):
#0 0x00007f0ec5d9ea64 in outputLineInternal (this=0x7f0e7c0024e0, line=<value optimized out>) at extmodule.cpp:1250
0000001 (anonymous namespace)::ExtModReceiver::outputLine (this=0x7f0e7c0024e0, line=<value optimized out>) at extmodule.cpp:1222
0000002 0x00007f0ec5d9eaa7 in (anonymous namespace)::ExtModReceiver::returnMsg (this=0x7f0e7c0024e0, msg=<value optimized out>, id=<value optimized out>, accepted=<value optimized out>) at extmodule.cpp:1269
0000003 0x00007f0ec5d9eb00 in (anonymous namespace)::ExtMessage::~ExtMessage (this=0x7f0e10003510, __in_chrg=<value optimized out>) at extmodule.cpp:616
0000004 0x00007f0ec5d9eb39 in (anonymous namespace)::ExtMessage::~ExtMessage (this=0x7f0e10003510, __in_chrg=<value optimized out>) at extmodule.cpp:619
0000005 0x00007f0ec6c6354c in TelEngine::MessageDispatcher::dequeueOne (this=0x12ad378) at Message.cpp:535
0000006 0x00007f0ec6c63590 in TelEngine::MessageDispatcher::dequeue (this=0x12ad378) at Message.cpp:541
0000007 0x00007f0ec6c65b95 in TelEngine::EnginePrivate::run (this=<value optimized out>) at Engine.cpp:843
0000008 0x00007f0ec6c474c5 in TelEngine::ThreadPrivate::run (this=0x1345ca0) at Thread.cpp:349
0000009 0x00007f0ec6c47509 in TelEngine::ThreadPrivate::startFunc (arg=<value optimized out>) at Thread.cpp:552
0000010 0x0000003e346079d1 in start_thread () from /lib64/libpthread.so.0
0000011 0x0000003e342e8b6d in clone () from /lib64/libc.so.6

Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000548)
paulc (administrator)
2014-07-03 13:51

This problem should be fixed in SVN Rev 5858 (2014-06-30).

It was caused by a race condition between the message handler and the closeOut() called during ExtModReceiver cleanup.

- Issue History
Date Modified Username Field Change
2014-07-03 12:59 fed New Issue
2014-07-03 13:51 paulc Note Added: 0000548
2014-07-03 13:51 paulc Status new => resolved
2014-07-03 13:51 paulc Resolution open => fixed


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker