Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000397 [Yate - Yet Another Telephony Engine] module major always 2015-08-18 12:31 2015-08-24 11:51
Reporter ych View Status public  
Assigned To paulc
Priority normal Resolution fixed  
Status feedback   Product Version SVN
Summary 0000397: yradio compile error on Mac OS X of SVN Rev: 6017
Description After update to SVN Rev: 6017 during yate compile on Mac OS X 10.10.4 get next compile error

radio.cpp:418:18: error: use of undeclared identifier 'htobe32'
        *(uint32_t*)d = htobe32(len);
                        ^
radio.cpp:419:24: error: use of undeclared identifier 'htobe64'
        *(uint64_t*)(d + 4) = htobe64(ts);
                              ^
radio.cpp:422:18: error: use of undeclared identifier 'htole32'
        *(uint32_t*)d = htole32(len);
                        ^
radio.cpp:423:24: error: use of undeclared identifier 'htole64'
        *(uint64_t*)(d + 4) = htole64(ts);
                              ^
radio.cpp:461:8: error: use of undeclared identifier 'be32toh'
        len = be32toh(*u);
              ^
radio.cpp:463:8: error: use of undeclared identifier 'le32toh'
        len = le32toh(*u);
              ^
radio.cpp:468:8: error: use of undeclared identifier 'be64toh'
        len = be64toh(*p);
              ^
radio.cpp:470:8: error: use of undeclared identifier 'le64toh'
        len = le64toh(*p);
              ^
radio.cpp:503:11: error: use of undeclared identifier 'be16toh'
            *p = be16toh(*p);
                 ^
radio.cpp:512:11: error: use of undeclared identifier 'be32toh'
            *p = be32toh(*p);
                 ^
radio.cpp:521:11: error: use of undeclared identifier 'be64toh'
            *p = be64toh(*p);
                 ^
Additional Information $ g++ --version
Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk/usr/include/c++/4.2.1
Apple LLVM version 6.1.0 (clang-602.0.53) (based on LLVM 3.6.0svn)
Target: x86_64-apple-darwin14.4.0
Thread model: posix
Tags No tags attached.
Attached Files ? file icon radio.cpp.diff [^] (1,738 bytes) 2015-08-24 11:51

- Relationships

-  Notes
(0000599)
paulc (administrator)
2015-08-18 14:27

Should be fixed by Rev. 6018 that provides replacements for those missing macros.
Please confirm that the issue is fixed.
(0000600)
ych (reporter)
2015-08-18 15:01

On SVN Rev: 6018 everything compiles without error.
Thanks.
(0000601)
ych (reporter)
2015-08-24 11:48

Ups... Sorry for mistaken report about success compile on OS X (I think I forgot revert my temp patch, when test Rev. 6018).
I just try to recompile last fresh checkouted source and got:

radio.cpp:27:10: fatal error: 'byteswap.h' file not found
#include <byteswap.h>
         ^

OS X does not have this header in its standard include paths :(.
(0000602)
ych (reporter)
2015-08-24 11:51

Add radio.cpp.diff file with fix for this issue on OS X native way.

- Issue History
Date Modified Username Field Change
2015-08-18 12:31 ych New Issue
2015-08-18 14:27 paulc Note Added: 0000599
2015-08-18 14:27 paulc Assigned To => paulc
2015-08-18 14:27 paulc Status new => feedback
2015-08-18 14:27 paulc Resolution open => fixed
2015-08-18 15:01 ych Note Added: 0000600
2015-08-24 11:48 ych Note Added: 0000601
2015-08-24 11:51 ych File Added: radio.cpp.diff
2015-08-24 11:51 ych Note Added: 0000602


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker