Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000422 [Yate - Yet Another Telephony Engine] module minor always 2018-06-09 07:11 2018-06-11 14:36
Reporter cotequeiroz View Status public  
Assigned To paulc
Priority normal Resolution fixed  
Status resolved   Product Version SVN
Summary 0000422: Yate will not build with openssl 1.1.0 compiled without deprecated API
Description Openssl 1.1.0 deprecated SSLv23_method, and changed library initialization. TLS_method() is used instead of SSLv23_method. As for initialization, it is not needed anymore. There are new functions for initialization, but they are only needed in special cases (not wanting to load error messages, for example).
Additional Information I attached a patch that fixes the issues. Since the purpose of the patch is to update the deprecated API, I left the new API in the main code, and added a #define for TLS_method. I also changed the change from AES_ctr128_encrypt to CRYPTO_ctr128_encrypt, to maintain the new API in the code.
Tags No tags attached.
Attached Files ? file icon 170-Remove-openssl-1.1-deprecated-API.patch [^] (2,365 bytes) 2018-06-09 07:11

- Relationships

-  Notes
(0000622)
paulc (administrator)
2018-06-11 14:36

Should be resolved by Rev. 6316: Detect and deal with some OpenSSL 1.1.0 deprecations.

We avoid messing with specific versions, use autoconf feature detection instead.

- Issue History
Date Modified Username Field Change
2018-06-09 07:11 cotequeiroz New Issue
2018-06-09 07:11 cotequeiroz File Added: 170-Remove-openssl-1.1-deprecated-API.patch
2018-06-11 14:36 paulc Note Added: 0000622
2018-06-11 14:36 paulc Assigned To => paulc
2018-06-11 14:36 paulc Status new => resolved
2018-06-11 14:36 paulc Resolution open => fixed


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker