Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000008 [Yate - Yet Another Telephony Engine] module minor always 2005-12-08 20:43 2006-06-11 13:36
Reporter maciejka View Status public  
Assigned To paulc
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0000008: Semicolon in regexproute interferes with sip urls
Description There are legal sip urls that can't be used in regexproute because of regexproute semicolon semantics, for example:
sip:0228699352@easycall.pl;user=1234
will be cut to:
sip:0228699352@easycall.pl

mk
 
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000033)
paulc (administrator)
2006-06-11 13:36

Solved by adding a regexroute function that generates the separator character.
The function is $() - that is, empty name.

sip:0228699352@easycall.pl$()user=1234;param=val

now calls sip:0228699352@easycall.pl;user=1234 and sets 'param' to 'val'

- Issue History
Date Modified Username Field Change
2005-12-08 20:43 maciejka New Issue
2005-12-12 21:31 paulc Severity major => minor
2005-12-12 21:31 paulc Status new => acknowledged
2005-12-12 21:32 paulc Status acknowledged => assigned
2005-12-12 21:32 paulc Assigned To => paulc
2005-12-12 21:41 paulc Category => module
2006-06-11 13:36 paulc Note Added: 0000033
2006-06-11 13:36 paulc Status assigned => closed
2006-06-11 13:36 paulc Resolution open => fixed


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker